文华公式主图K红多绿空标题图片

文华公式主图K红多绿空


主趋势线:EMA(EMA(C,10),10),COLORRED,LINETHICK3;
红色k线做多,如果下一根是白色就平仓等待,绿色做空,如果下一根是白色就平仓等待,红色做多,遇下一根k线绿色就平仓反手做空,绿色做空,遇下一根k线红色就平仓反手做多,白色k线只平仓不开仓,



B:=主趋势线 REF(主趋势线,1);IF(B-1,主趋势线,NULL),COLORBLUE,LINETHICK3;
AA:=EMA(C,5) EMA(C,20);BB:=EMA(C,5) EMA(C,20);CC:= EMA(C,5) EMA(C,10);CC1:=EMA(C,5) EMA(C,10);DD:=CLOSE OPEN;STICKLINE1(AA,H,L,0,0),COLORRED;STICKLINE1(AA,O,C,3,1),COLORRED;STICKLINE1(AA AND DD,O,C,3,0),COLORRED;STICKLINE1(BB,H,L,0,0),COLORGREEN;STICKLINE1(BB,O,C,3,1),COLORGREEN;STICKLINE1(BB AND DD,O,C,3,0),COLORGREEN;STICKLINE1(BB AND CC,H,L,0,1),COLORWHITE;STICKLINE1(BB AND CC,O,C,3,1),COLORWHITE;STICKLINE1(BB AND CC AND DD,O,C,3,0),COLORWHITE;STICKLINE1(AA AND CC1,H,L,0,0),COLORWHITE;STICKLINE1(AA AND CC1,O,C,3,1),COLORWHITE;STICKLINE1(AA AND CC1 AND DD,O,C,3,0),COLORWHITE;AA NOT(CC1),BPK;BB NOT(CC),SPK;BB AND CC || AA AND CC1,SP;BB AND CC || AA AND CC1,BP;AUTOFILTER;








主趋势线:EMA(EMA(C,10),10),COLORRED,LINETHICK3;

B:=主趋势线 REF(主趋势线,1);
IF(B-1,主趋势线,NULL),COLORWHITE,LINETHICK3;

AA:=EMA(C,5) EMA(C,20);
BB:=EMA(C,5) EMA(C,20);
CC:= EMA(C,5) EMA(C,10);
CC1:=EMA(C,5) EMA(C,10);
DD:=CLOSE OPEN;

STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(AA,O,C,3,1),COLORRED;
STICKLINE(AA AND DD,O,C,3,0),COLORRED;
STICKLINE(BB,H,L,0,0),COLORGREEN;
STICKLINE(BB,O,C,3,1),COLORGREEN;


STICKLINE(BB AND DD,O,C,3,0),COLORGREEN;
STICKLINE(BB AND CC,H,L,0,1),COLORWHITE;
STICKLINE(BB AND CC,O,C,3,1),COLORWHITE;
STICKLINE(BB AND CC AND DD,O,C,3,0),COLORWHITE;
STICKLINE(AA AND CC1,H,L,0,0),COLORWHITE;
STICKLINE(AA AND CC1,O,C,3,1),COLORWHITE;
STICKLINE(AA AND CC1 AND DD,O,C,3,0),COLORWHITE;








N: =25;
N2: =3;
N3: =5;
M1: =6;
M2: =6;

UPPER:(1+M1/100)*MA(CLOSE,N),COLORGREEN,POINTDOT, LINETHICK2;
LOWER:(1-M2/100)*MA(CLOSE,N),COLORGREEN,POINTDOT, LINETHICK2;
MA5:EMA(C,5),COLORWHITE;
工作线:EMA(C,14),COLORF00FF0,LINETHICK2;
二号线:EMA(C,25),COLOR00FF00,LINETHICK2;
九号线:EMA(CLOSE,99),LINETHICK1;
MA120:EMA(CLOSE,120),LINETHICK1;
生命线:EMA(CLOSE,250),COLORRED,LINETHICK2;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19));
DEA:=EMA(DIFF,9);
MACD:=0.90*(DIFF-DEA);
TJ:=(DIFF =DEA);
TJ1:=(DIFF
STICKLINE(TJ,H,L,0.3,0),COLORYELLOW;
STICKLINE(TJ,O,C,3,0),COLORYELLOW;
STICKLINE(TJ1 AND TJ,H,L,0.3,0),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,3,1),COLORF00FF0;
STICKLINE(DIFF DEA,H,L,0.3,0),COLORF0F000;
STICKLINE(DIFF DEA,O,C,3,0),COLORF0F000;
J:=(CLOSE+HIGH+LOW)/3;
A:=EMA(J,10);
B:=REF(A,1);
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS(CLOSE-REF(CLOSE,1)),7)*100;
VAR9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS(CLOSE-REF(CLOSE,1)),13)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8 20 AND VAR9 23 AND VARA
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGH(3,6,1,1) 4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGH(3,16,1,1)=0 AND HIGH LOW+0.04,4,0);
VAR11:=ZIGZAG(3,6,1) REF(ZIGZAG(3,6,1),1) AND REF(ZIGZAG(3,6,1),1) =REF(ZIGZAG(3,6,1),2) AND REF(ZIGZAG(3,6,1),2) =REF(ZIGZAG(3,6,1),3);
VAR12:=ZIGZAG(3,6,1) REF(ZIGZAG(3,6,1),1) AND REF(ZIGZAG(3,6,1),1) =REF(ZIGZAG(3,6,1),2) AND REF(ZIGZAG(3,6,1),2) =REF(ZIGZAG(3,6,1),3);
VAR13:=ZIGZAG(3,22,1) REF(ZIGZAG(3,22,1),1) AND REF(ZIGZAG(3,22,1),1) =REF(ZIGZAG(3,22,1),2) AND REF(ZIGZAG(3,22,1),2) =REF(ZIGZAG(3,22,1),3);
VAR14:=ZIGZAG(3,22,1) REF(ZIGZAG(3,22,1),1) AND REF(ZIGZAG(3,22,1),1) =REF(ZIGZAG(3,22,1),2) AND REF(ZIGZAG(3,22,1),2) =REF(ZIGZAG(3,22,1),3);
VAR15:=ZIGZAG(3,51,1) REF(ZIGZAG(3,51,1),1) AND REF(ZIGZAG(3,51,1),1) =REF(ZIGZAG(3,51,1),2) AND REF(ZIGZAG(3,51,1),2) =REF(ZIGZAG(3,51,1),3);
VAR16:=ZIGZAG(3,51,1) REF(ZIGZAG(3,51,1),1) AND REF(ZIGZAG(3,51,1),1) =REF(ZIGZAG(3,51,1),2) AND REF(ZIGZAG(3,51,1),2) =REF(ZIGZAG(3,51,1),3);
VAR17:=ZIGZAG(3,72,1) REF(ZIGZAG(3,72,1),1) AND REF(ZIGZAG(3,72,1),1) =REF(ZIGZAG(3,72,1),2) AND REF(ZIGZAG(3,72,1),2) =REF(ZIGZAG(3,72,1),3);
VAR18:=ZIGZAG(3,72,1) REF(ZIGZAG(3,72,1),1) AND REF(ZIGZAG(3,72,1),1) =REF(ZIGZAG(3,72,1),2) AND REF(ZIGZAG(3,72,1),2) =REF(ZIGZAG(3,72,1),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
买点1:=VAR10;
买点2:=(VAR11+VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18){,LINETHICK2};
VAR22:=买点1 AND VARF AND VARC AND VAR21 AND VAR4 0 AND VAR5=0 AND VAR6=0 AND VAR20 (-110);
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,14);
VAR31:=MA(CLOSE,25);
VARB1:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC1:=INTPART(VARB1*100)/100;
VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE1:=EMA(VARD1,9);
VAR131:=REF(VARE1,1);
VAR141:=VARE1;
VAR151:=VAR141-VAR131;
VAR161:=REF(VARD1,1);
VAR171:=VARD1;
VAR181:=VAR171-VAR161;
VAR191:=OPEN;
VAR1A1:=CLOSE;
买点3:=IF(VAR19 =VAR1 AND VAR191 =VAR2 AND VAR191 =VAR31 AND VAR1A1 =VAR1 AND VAR1A1 =VARC1 AND VAR151 0 AND VAR181 0,0.5,0);
DRAWICON(买点3 0,L-0.01,1);
DRAWTEXT(买点1 0,L-0.01,'起☆'),COLOR0000FF;
DRAWTEXT(买点2 0,L-0.01,'起★'),COLOR0000FF;
DRAWTEXT(卖点1 0,H+0.1,'卖▲'),COLOR00FF00;









//DRAWTEXT_FIX(1,0.035,0.06,0,'主题投资----------')COLOR00FF00;//DRAWTEXT_FIX(1,0.12,0.06,0,EXTERNSTR(0,1))COLOR00FF00;AA:=(CLOSE+OPEN+HIGH+LOW)/4;N:=6;A1:=EMA((EMA(AA,N-1)+EMA(AA,N)+EMA(AA,N+1))/3,3);A2:=EMA((EMA(AA,N+2)+EMA(AA,N+3)+EMA(AA,N+4))/3,3),DOT ;A3:=EMA((EMA(AA,N+5)+EMA(AA,N+6)+EMA(AA,N+8))/3,3),DOT;A4:=EMA((EMA(AA,N+11)+EMA(AA,N+9)+EMA(AA,N+10))/3,3);A5:=EMA((EMA(AA,N+15)+EMA(AA,N+16)+EMA(AA,N+17))/3,3);
IF(A1 =A2 OR A1 =A3 OR A1 =A4,A1,A1),COLORRED;IF(A1 =A2 OR A1 =A3 OR A1 =A4,A2,A2),COLORRED,DOT;IF(A1 =A2 OR A1 =A3 OR A1 =A4,A3,A3),COLORRED,DOT;IF(A1 =A2 OR A1 =A3 OR A1 =A4,A4,A4),COLORRED;
IF(A1 =A2 OR A1 =A3 OR A1 =A4,A1,NULL),COLORGREEN;IF(A1 =A2 OR A1 =A3 OR A1 =A4,A2,NULL),COLORGREEN,DOT;IF(A1 =A2 OR A1 =A3 OR A1 =A4,A3,NULL),COLORGREEN,DOT;IF(A1 =A2 OR A1 =A3 OR A1 =A4,A4,NULL),COLORGREEN;A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1) =9.8/100;STICKLINE1(A,H,L,0,0),COLORYELLOW,LINETHICK2;STICKLINE1(A AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORYELLOW,LINETHICK1;B:=(REF(CLOSE,1)-CLOSE)/CLOSE =9.8/100;STICKLINE1(B,H,L,0,0),COLORGREEN,LINETHICK2;STICKLINE1(B AND CLOSE=OPEN AND HIGH=LOW AND CLOSE REF(CLOSE,1),REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;STICKLINE1(B,O,C,3,0),COLOR008800;STICKLINE1(B,O,C,2,0),COLOR00AA00;STICKLINE1(B,O,C,1,0),COLOR00CC00;STICKLINE1(B,O,C,0.2,0),COLOR00FF00;STICKLINE1(A,O,C,3,0),COLOR008888;STICKLINE1(A,O,C,2,0),COLOR00AAAA;STICKLINE1(A,O,C,1,0),COLOR00CCCC;STICKLINE1(A,O,C,0.2,0),COLOR00FFFF;DRAWKLINE1(HIGH,OPEN,LOW,CLOSE);



HH:=HHV(HIGH,13);LL:=LLV(LOW,13);HH1:=BARSLAST((HH REF(HH,1)));LL1:=BARSLAST((LL REF(LL,1)));A:=IFELSE((HH1 LL1),1,IFELSE((HH1 LL1),-1,0));AA:IFELSE(A =0,LL,HH),COLORWHITE;DRAWTEXT(CROSS(HH1,LL1),HH,'开空');DRAWTEXT(CROSS(LL1,HH1),LL,'开多');//突击破位战法:PB1:(EMA(CLOSE,9)+MA(CLOSE,9*2)+MA(CLOSE,9*4))/3,COLORBLACK;PB2:(EMA(CLOSE,20)+MA(CLOSE,20*2)+MA(CLOSE,20*4))/3,COLORBLACK;PB3:(EMA(CLOSE,30)+MA(CLOSE,30*2)+MA(CLOSE,30*4))/3,COLORBLACK;EMA51:EMA(CLOSE,61);DRAWCOLORLINE(C =EMA51,EMA51,COLORRED,COLORGREEN),LINETHICK2;COLORRED;DRAWCOLORKLINE(CROSS(C,AA),COLORRED,0);DRAWCOLORKLINE(CROSSDOWN(C,AA),COLORGREEN,0);CROSS(C,AA),SOUND('A');CROSSDOWN(C,AA),SOUND('B');


最新回复 (0)
    • 小鱼在线
      2
          喵
返回